Commit ed231939 authored by Côme Chilliet's avatar Côme Chilliet
Browse files

Fixes #4659 Fixed flattening of dependencies when askme is used

parent fc65dfc7
...@@ -644,7 +644,12 @@ class plugin ...@@ -644,7 +644,12 @@ class plugin
array_map( array_map(
function ($a) use (&$cache, $depends, $forbidden) function ($a) use (&$cache, $depends, $forbidden)
{ {
return plugin::tpl_depends_of ($cache, $depends, $a, $forbidden); $deps = plugin::tpl_depends_of ($cache, $depends, $a, $forbidden);
if (($askmeKey = array_search('askme', $deps)) !== FALSE) {
/* Do not flat special askme dependency */
unset($deps[$askmeKey]);
}
return $deps;
}, },
$depends[$key] $depends[$key]
); );
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment